Cent OS 7.6にPHPをインストールする(Word Pressインストールの準備)

Word Pressインストールの準備としてPHPをインストールしておきます。

こんな感じです。

$ yum install php php-mbstring php-mysql
読み込んだプラグイン:fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: ftp.iij.ad.jp
 * extras: ftp.iij.ad.jp
 * updates: ftp.iij.ad.jp
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> パッケージ php.x86_64 0:5.4.16-46.el7 を インストール
--> 依存性の処理をしています: php-common(x86-64) = 5.4.16-46.el7 のパッケージ: php-5.4.16-46.el7.x86_64
--> 依存性の処理をしています: php-cli(x86-64) = 5.4.16-46.el7 のパッケージ: php-5.4.16-46.el7.x86_64
---> パッケージ php-mbstring.x86_64 0:5.4.16-46.el7 を インストール
---> パッケージ php-mysql.x86_64 0:5.4.16-46.el7 を インストール
--> 依存性の処理をしています: php-pdo(x86-64) = 5.4.16-46.el7 のパッケージ: php-mysql-5.4.16-46.el7.x86_64
--> トランザクションの確認を実行しています。
---> パッケージ php-cli.x86_64 0:5.4.16-46.el7 を インストール
---> パッケージ php-common.x86_64 0:5.4.16-46.el7 を インストール
--> 依存性の処理をしています: libzip.so.2()(64bit) のパッケージ: php-common-5.4.16-46.el7.x86_64
---> パッケージ php-pdo.x86_64 0:5.4.16-46.el7 を インストール
--> トランザクションの確認を実行しています。
---> パッケージ libzip.x86_64 0:0.10.1-8.el7 を インストール
--> 依存性解決を終了しました。

依存性を解決しました

================================================================================
 Package              アーキテクチャー
                                     バージョン              リポジトリー  容量
================================================================================
インストール中:
 php                  x86_64         5.4.16-46.el7           base         1.4 M
 php-mbstring         x86_64         5.4.16-46.el7           base         505 k
 php-mysql            x86_64         5.4.16-46.el7           base         101 k
依存性関連でのインストールをします:
 libzip               x86_64         0.10.1-8.el7            base          48 k
 php-cli              x86_64         5.4.16-46.el7           base         2.7 M
 php-common           x86_64         5.4.16-46.el7           base         565 k
 php-pdo              x86_64         5.4.16-46.el7           base          99 k

トランザクションの要約
================================================================================
インストール  3 パッケージ (+4 個の依存関係のパッケージ)

総ダウンロード容量: 5.4 M
インストール容量: 19 M
Is this ok [y/d/N]: y
Downloading packages:
(1/7): libzip-0.10.1-8.el7.x86_64.rpm                      |  48 kB   00:00
(2/7): php-5.4.16-46.el7.x86_64.rpm                        | 1.4 MB   00:00
(3/7): php-cli-5.4.16-46.el7.x86_64.rpm                    | 2.7 MB   00:00
(4/7): php-common-5.4.16-46.el7.x86_64.rpm                 | 565 kB   00:00
(5/7): php-mysql-5.4.16-46.el7.x86_64.rpm                  | 101 kB   00:00
(6/7): php-mbstring-5.4.16-46.el7.x86_64.rpm               | 505 kB   00:00
(7/7): php-pdo-5.4.16-46.el7.x86_64.rpm                    |  99 kB   00:00
--------------------------------------------------------------------------------
合計                                               5.4 MB/s | 5.4 MB  00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  インストール中          : libzip-0.10.1-8.el7.x86_64                      1/7
  インストール中          : php-common-5.4.16-46.el7.x86_64                 2/7
  インストール中          : php-pdo-5.4.16-46.el7.x86_64                    3/7
  インストール中          : php-cli-5.4.16-46.el7.x86_64                    4/7
  インストール中          : php-5.4.16-46.el7.x86_64                        5/7
  インストール中          : php-mysql-5.4.16-46.el7.x86_64                  6/7
  インストール中          : php-mbstring-5.4.16-46.el7.x86_64               7/7
  検証中                  : php-mysql-5.4.16-46.el7.x86_64                  1/7
  検証中                  : php-pdo-5.4.16-46.el7.x86_64                    2/7
  検証中                  : php-cli-5.4.16-46.el7.x86_64                    3/7
  検証中                  : libzip-0.10.1-8.el7.x86_64                      4/7
  検証中                  : php-mbstring-5.4.16-46.el7.x86_64               5/7
  検証中                  : php-5.4.16-46.el7.x86_64                        6/7
  検証中                  : php-common-5.4.16-46.el7.x86_64                 7/7

インストール:
  php.x86_64 0:5.4.16-46.el7            php-mbstring.x86_64 0:5.4.16-46.el7
  php-mysql.x86_64 0:5.4.16-46.el7

依存性関連をインストールしました:
  libzip.x86_64 0:0.10.1-8.el7             php-cli.x86_64 0:5.4.16-46.el7
  php-common.x86_64 0:5.4.16-46.el7        php-pdo.x86_64 0:5.4.16-46.el7

完了しました!

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です